Japhoto - blog

Blog navigation tweaks…

without comments

There have been a couple of things on the blog that have been bothering me.

Because this blog is about photos, they remain my main concern and although I do like the present theme, there are a few things wrong with it. I’m using photos that are 800px wide (or tall) on the blog and the present layout doesn’t allow me to display landscape photos in full-size. I’m looking into this and the options are to modify this theme (a lot of work) or finding a new, more suitable theme for displaying photos.

I did manage to fix a few issues, so here they are:

Firstly, when you’ve clicked on an image, it has opened to an attachment page. The only purpose would be to get comments on image by image basis, but since there are only about 10-20 images per post on average, I don’t see the need for this.

This linking behavior has been changed so that when you click an image, it opens only the image on white background and at the native size. When opened to the attachment page, the landscape images still didn’t open in full-size and you had to click it once more to get it to open like it does now.

I’ve also made the first image (the one you see on the “main” page) into a thumbnail, so when you click it, it opens the whole post. This works with the “Read more” – button, but the latter makes a jump to the part where the “Read more” – tag is (it doesn’t open the post from the beginning). I have instructions how to make the “Read more” – button to open the post from the beginning, but that requires some coding.

I’m also looking into a some sort of lightbox add-on for WordPress, since I’d like to have the images open to full-size like they do now, but on a darker background. I’ll post more about that if I find a suitable one.

The tweaks mentioned above have been implemented on all posts and have also been tested, so they should be working now.

Next up is probably some visual tweaks to the theme, but more on that later…

Edit: I found a lightbox plugin and it’s up and running. It solved a few issues, but now I’ll have to figure out how to get the first images on each post to show in the lightbox as well…

Edit 2: “Read more” – button opens a post from the beginning now and doesn’t jump down anymore.

Janne

23.04.2011 at 14:56

Leave a Reply